Upgrading WordPress

Maybe someone can help me out here. It seems to me that wordpress is lacking some support for upgrades with SSL. For example, I do not have FTP open on my web server and I have no plans to open it up in the future. I DO however support ftp over ssh also known as sftp. But when I click on the ‘automatically upgrade’ link in the plugins directory, here is the screen that I am greeted with.

Screen shot 2009-10-27 at 11.52.35 PM

First off, there are 2 things wrong with this screen.

1) As I mentioned before, it only supports ftp, not sftp.

2) Its not an option if there is only one choice! Just show the connection type as FTP.

Someone help me out here. If you have a better way of upgrading securely, I’d like to hear it.

Comments are closed.